Jump to content
Age of Civilizations

blindidiot91

Gentleman
  • Content Count

    1
  • Joined

  • Last visited

  1. [468,369],[467,370],[493,345],[469,369],[493,346],[470,369],[493,347],[471,369],[493,348],[472,369],[493,349],[473,369],[493,350],[474,369],[493,351],[475,369],[476,369],[494,352],[477,369],[494,353],[478,369],[494,354],[479,369],[494,355],[480,369],[494,356],[481,369],[494,357],[482,369],[494,358],[483,369],[494,359],[484,369],[494,360],[485,369],[494,361],[486,369],[494,362],[487,369],[494,363],[489,368],[488,369],[490,368],[495,364],[491,368],[495,365],[492,368],[495,366],[493,368],[495,367],[494,368], Exception in thread "main" java.util.NoSuchElementException at java.util.LinkedList.getLast(Unknown Source) at Main.returnEdgeByDirection(Main.java:633) at Main.returnEdgeByDirection(Main.java:622) at Main.start(Main.java:69) at Main.main(Main.java:21) I'm trying to make a new map from a province map I used without issue in a mod for ck2. I can't figure out what's going on here with this error. It seems to get past all the outer ocean provinces and then get stuck. I've tried removing provinces to see if I can isolate a specific problem with one of them, but as I remove them (either by converting them to a transparency or merging with another province), it just throws an error on the next province it gets to. The map is below [removed once issue discovered]. **Update here: it was the one province issues. I modified the code to show me the last blob it got stuck on and just stepped through until all of the one provinces were gone.**
×
×
  • Create New...