Jump to content
Age of Civilizations
Ànex i Rux

Economy Bug

Recommended Posts

i am facing have the same issue. The only way to solve it is to abandon the province and buy it again, then work on improving the economy as soon as possible, which is a costly technique.

 

This glitch needs to be changed as soon as possible. It is hard to improve the economy while this glitch is present

Share this post


Link to post
Share on other sites

This is happening to me as well and it frequently occurs with the A.I. after they fight long wars. When you take their provinces through peace conferences,  the economy of some remains stuck at 99 even after attempting to invest in the economy multiple times, it's extremely frustrating.

Edited by XiaoDabao

Share this post


Link to post
Share on other sites
Guest Adamos

I did have about 20 provinces like this.. most of them I got from 99 up via investments, but 10 of them were stuck at 99, sometimes got to 101,102, but always fell back to 99. Then I've saved some money and put investment slider to 100% and started againg heavy manual investmens and most of them went up with economy to safe numbers. However 2 stayed down.. Even moving capital there didn't work.. I guess it was wore down too much by warfare - so there I used cheatcode economy to get +600...

Share this post


Link to post
Share on other sites

Vendex_thegreatest, Thank you so much, this method does work. Just abandon it, colonize it, and invest, and BOOM just like that, the economy starts working again. This fixes it. Thank you.

 

Edit: Only downside is that population in the province is cut by like 75% after abandoning it. My 30,000 population city went down to 7,000 after I recolonized it 😕 But I got the province's economy up to 20,000 🙂

Edited by Venboven

Share this post


Link to post
Share on other sites

INTERESTINGLY, if you raise those economies with the "economy" cheat via console (which adds 600 economy to the province) and also raise its development level with investments, it drops back to 99 faster compared to a lower development level. So it's pointing to a simple math sign issue somewhere in the code or something wrong with the default values of those particular provinces. Should be an easy fix?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Jacob Sisson
      I'm trying to create a new leader but it wont save, I have tried over and over again but it still wont work, I even installed the app again to see if it would work, I'm pretty sure I remember it working before . I dont know if I'm doing something wrong. I've just tried typing a name and adding a civilization and nothing saves.
    • By specseaver
      The Diplomacy map mode suddenly doesn't work on iOS (in my case, ipadOS). Pressing the button at the top does nothing, and selecting under the map modes tab makes the map flicker and either crash or freeze. Is this happening for other on ipad, and if not, is there a possible fix?
    • By Lativ
      Me and my friend made a petition, let's show Łukasz how many of us there are! Link below.
      https://www.change.org/p/łukasz-jakowski-save-age-of-civilizations-2
    • By YuraTheGreat
      I decided to create a discussion where I include a small number of bugs.
      immediately i will say - my English knowledge very bad, sorry if you will see some mistakes 😕

      -on this screenshot ai trying to attack with small amount of troops. eventually this impossible, because in game has limit of minimum troops to attack 10.

      -on this screenshot you can see rebels who could not to form a state. p.s you cannot go into diplomacy with him. p.s.s also there russia conquered Serbia, and after signing the peace Serbian provinces steel looks like occupation.


      -on this two screenshots you can see how Belgium population and economy resets to zero after creating a vassal. p.s this is a scenario of ww1 maded by me

      -on this screenshot can see troops of north korea in occupation of south korea. before that I concluded alliance with south korea and declared war on north korea. 
      at the end of the war all my troops were destroyed to zero, but in statistic i has 5,324. 
      generally buggy system war with allies. sometimes the enemy may attack with 100 troops the occupation of your allies, where is 500 of your troops, and win.
       
      I think about glitch kinda "opinion resets to 0.0" everybody knows, then I don't put this in my list.
      I want to contact to game developer: please, at least fix these bugs. not only me are big fan of this game. I know many people who very likes this game and waiting for updates. I still waiting for update march 2020...
    • By Tiwoe
      I was just playing and suddenly the screen started glitching (blinking) and I couldn't click anywhere so i just alt+f4 out of the game. After that i just shut down my pc. The next day when I went into aoc2 again every scenario was gone, there was only one left with the name "Test" which only included 2 provinces in Iberia. I also tried to create my own scenario but the two provinces were the only ones on the whole map i could choose. I tried to delete the game and install it again but nothing happened. How can I reset this?
×
×
  • Create New...