Jump to content
Age of Civilizations
OrangeBlueHue

Autosave Bug

Recommended Posts

There is a pretty bad bug regarding autosaves. Every so often, after an autosave is complete, the game will continuously do autosaves after every single turn. The game doesn't actually save though, and even if you manually save, the game will lose data up until the previous save, before the autosave glitch occurs.

Example: Autosave complete (turn 100), Autosave complete (turn 200), Autosave bug occurs (turn 201).

The game will only have the game saved at turn 100, not 200, losing an incredible amount of time if you happen to change your autosave intervals to be higher.

Share this post


Link to post
Share on other sites
4 hours ago, OrangeBlueHue said:

I can't seem to find what is causing it. It happens regardless of if you mess with the autosave intervals or not. I literally cannot play this game because of this bug.

Do you have this problem in every game mode or only in civilizations mode (Random mode)?

I have the same problem only in civilizations mode

Share this post


Link to post
Share on other sites
On 1/3/2019 at 3:35 AM, OrangeBlueHue said:

There is a pretty bad bug regarding autosaves. Every so often, after an autosave is complete, the game will continuously do autosaves after every single turn. The game doesn't actually save though, and even if you manually save, the game will lose data up until the previous save, before the autosave glitch occurs.

Example: Autosave complete (turn 100), Autosave complete (turn 200), Autosave bug occurs (turn 201).

The game will only have the game saved at turn 100, not 200, losing an incredible amount of time if you happen to change your autosave intervals to be higher.

Never saw it. Hopefully someone else discovers why it happens and can shine some light on it though.

Share this post


Link to post
Share on other sites

Could it have something to do with not enough RAM being used or too much being used? I've noticed games with turns upwards of a couple hundred will start using up 3-4 gigs of RAM or more and will often freeze up for a few seconds on a civ while the turns are being processed. I tested to see if the autosave bug would occur if I didn't manually end my turn, and 'unpaused' the game. After it tries to save it tells me that not enough RAM was allocated and that the save failed, despite having plenty of RAM to spare (16 gigs)

edit: I just checked the store page recommended RAM usage and it says the recommended amount of RAM should be 2 gigs, so why is it going to 4 and above?

Edited by OrangeBlueHue

Share this post


Link to post
Share on other sites

At this point, I feel like it is due to poor optimization. Im tired of having this bug and literally tried everything here. At this point, with the lack of communication with the dev and the steam workshop coming to development, I doubt this bug will ever get fixed.

Share this post


Link to post
Share on other sites
51 minutes ago, Syzygy said:

At this point, I feel like it is due to poor optimization. Im tired of having this bug and literally tried everything here. At this point, with the lack of communication with the dev and the steam workshop coming to development, I doubt this bug will ever get fixed. 

Just wait he isn't robot.

Share this post


Link to post
Share on other sites
5 minutes ago, Wersjon said:

Just wait he isn't robot.

I understand this. But when you make a game that has had constant set backs/ release dates over and over again, you get tired of having to wait for another fix. I also know that the dev tried a patch which was to address this save situation but it didn't work for many of us. All im trying to say is that at this point, hope is getting lost for at least me anyway. Especally when on the steam forum and such, you don't have the dev addressing these bugs that are happening. It is worrying to me that the dev would rather work on new content when this game has so many bugs that it makes it hard if not impossible to play.

Share this post


Link to post
Share on other sites

Same with me.

The more civs are in the game and the more unoccupied/neutral provinces there are - the sooner bug will appear.

Obvious quick fix - add a real "turn off autosaves" setting, bc currently switching autosave interval to 0 don't fix this - autosave every turn will appear no matter what.

Don't know for sure, but it really seems related to ram and how java used it, but I have 32gb on board and my maximum usage by game was around 8gb.

Share this post


Link to post
Share on other sites
Guest Irisierende

Try turning off Fog of War (Classic Mode)

Share this post


Link to post
Share on other sites
On 1/18/2019 at 12:12 PM, Guest Irisierende said:

Try turning off Fog of War (Classic Mode)

This actually worked for me in age of civilizataions mode as well. I encourage others to turn off fog of war as well bc at this point, I think the bug has to do something with the fog of war.

Thanks for this tip! It really helped me out!

Share this post


Link to post
Share on other sites
On 1/23/2019 at 4:48 PM, Syzygy said:

This actually worked for me in age of civilizataions mode as well. I encourage others to turn off fog of war as well bc at this point, I think the bug has to do something with the fog of war.

Thanks for this tip! It really helped me out!

Unfortunately the bug still sets in eventually. I almost successfully reunited Rome as the Byzantine Empire including conquering all necessary territory only to be done in by this bug. I ended up deleting the game from my phone to eliminate all my achievements since I lost in the most disgraceful way possible so I don't deserve them.

Edited by SecretAgent632
Deleted sentence off topic.

Share this post


Link to post
Share on other sites
Guest Irisierende
On 1/24/2019 at 7:48 AM, Syzygy said:

This actually worked for me in age of civilizataions mode as well. I encourage others to turn off fog of war as well bc at this point, I think the bug has to do something with the fog of war.

Thanks for this tip! It really helped me out!

United Europe, Asia and Africa under Votadini (That small one province nation at Edinburg, scenario 5) until the bug did me in. Went on a fully bloody bug fix hunt after that. Good luck on your world conquests!

Share this post


Link to post
Share on other sites
Guest EMH

I've encountered the same error (on Android) . I started on the 1440 scenario as Scotland and had switched autosave to every turn. It was fine until around 1600 when I realised it hadn't saved progress (only the date). I think (but not 100% sure) that for a short while it would still save when you clicked the save button. It certainly has saved occasionally. But Ive probably lost several hours of play overall. Really frustrating as I don't want to play if it's not going to save my progress. Hope you can find the cause of it.  Thanks. 

Share this post


Link to post
Share on other sites

Newish player but I was having save bug happening tonight I cleared the cache for the civ app on my samsung 9 reloaded the game that was bugging and has seemed to fix it so far was able to do another 200 turns with auto save started working again each time.

Share this post


Link to post
Share on other sites
On 1/23/2019 at 11:48 PM, Syzygy said:

This actually worked for me in age of civilizataions mode as well. I encourage others to turn off fog of war as well bc at this point, I think the bug has to do something with the fog of war.

Thanks for this tip! It really helped me out!

But, how can i turn It off?

On 1/18/2019 at 12:51 PM, Guest Irisierende said:

Turn off Fog of War.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...