Jump to content
Age of Civilizations
Seboisthebest567

Please Help!!

Recommended Posts

I have been playing this game for about a week now and I love it but just started to have some problems!! So I go onto the title screen and press “games”. Then I press “new game”. And then I press the “1440” up top (to change the scenario of course”. But when I press that it randomly pops me back to the title screen!! Does any one have any ideas? If not I can still play, as the sliders next to the big button still work, so I can manually flick through until I get to the scenario I want. But it does mean I would be rendering the “editor” useless, as this bug happens when selecting a scenario to edit as well, and there are no sliders on editor. Any help would be appreciated. I have also attached photos.

613BE625-9B6B-4D9E-B7A8-4D97216440B6.jpeg

2296CC49-4AF8-42B7-B6B0-7938C523F60D.jpeg

32D127C5-9179-4864-BF88-90C1D4758CB0.jpeg

EB1F6DC3-46FE-4E62-ACE6-248851BE6DE8.jpeg

A7C59A1B-1538-4907-91DD-0A128744686A.jpeg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...