Jump to content
Age of History Games

I can't play

Recommended Posts

I love this game and even left a positive review on steam (flappingturtle3). And I just sold my laptop and am using an older pc for the moment. I started up my computer (windows 7) and it was really laggy and slow. I thought I'd take the free windows upgrade to windows 10 and reset my pc too so it might run faster. I downloaded steam and the game immediately ran the game. It showed it was running and then it just stopped. I ran it with task manager again and the application never even showed up. This confuses me because my computer meets the minim requirements and worked before I reset and upgraded to windows 10. Any thoughts on what to do? I really wanted to play this game again but can't and even reset my pc again. Please help as steam support lead me here.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Tell a friend

    Love Age of History Games? Tell a friend!

  • Posts

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Age of History Games