Jump to content
Age of History Games
KiooShimaa

I have problem with downloading

Recommended Posts

Hello! i have problem with downloading.I download all normally i extract but then when i open folder where i extracted there is all files except aoc2.exe i tried everything i tried deleting folder and try extracting again but same problem now i will try older version and see does it work thank you for making this mod 🙂

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Tell a friend

    Love Age of History Games? Tell a friend!

  • Posts

×
×
  • Create New...