Jump to content
Age of History Games

Help, AoC2 won't start

Recommended Posts

i have recently bought AoC2 on Steam, and i can't get it to load. when i click on "start" it then says "stop" for a few seconds, but doesn't launch and then goes back to saying "start".

confession: i have tried several times over 2 months going to steamunlocked and trying to get the game for free(before i realised i can just get steam giftcards(ya, ik, im a cheap idiot)), but it never worked as it always said that i dont have java bundled runtime enviroment.

my problem might be caused by the above, but i dont know why.

i am on a Samsung Notebook running Windows 11(i got it before i even knew what it does) so idk what to do

Notebook(incase you need to know): Samsung Galaxy Book Go 35,49cm (13,97 ) 4GB | Kaufland.de

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Tell a friend

    Love Age of History Games? Tell a friend!

  • Posts

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Age of History Games