Jump to content
Age of History Games

Won’t advance to next turn and diplomacy tab won’t open

Recommended Posts

I was playing the game and everything was fine until my screen started glitching. I exited the game and re entered it and when I tried to advance to the next turn, nothing happened. Also, when I tried to open the diplomacy tab, it wouldn’t open. These are game-breaking glitches. PLEASE FIX!!!

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Tell a friend

    Love Age of History Games? Tell a friend!

  • Posts

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Age of History Games