Jump to content
Age of History 3

kokakolabrooooo

HELP

Recommended Posts

Ok i've never had problems like this

yesterday i finished the map and tried it ingame,it worked fine

i edited sea provinces and just closed the game

now i tried it and it stops at 46%

but there isnt any mistake so idk what to do

i checked everything TWICE

pls help me,i've never had problems with maps

but now something happened

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Tell a friend

    Love Age of History 3? Tell a friend!

  • Posts

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Age of History Games