Jump to content
Age of History Games

Aoh 2 not working on windows 10

Recommended Posts

Hi, so me and my friend have both installed age of History 2,and when we try to turn it up, it doesnt work. It says that version of 1% isnt compatible with Windows. I tried a lot,but it still didnt worked. If someone could know can i fix this? Regards

Share this post

Link to post
Share on other sites

Maybe you deleted some files by accident or changed something in them.Try reinstalling the game again and say those that works.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Tell a friend

    Love Age of History Games? Tell a friend!

  • Posts

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Age of History Games