Jump to content
Age of History Games

Game not working/opening

Recommended Posts

When I try to open the game it's doesn't work.
No window, no error message or something.
In task manager it shows process but then it closes after few seconds.
I really wanna play this game but I can't...
I have opengl 2.1 and java lastest version.
I tried everything (reinstalling, checking files, running as admin, changing compatibility nothing worked).
plz help

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Tell a friend

    Love Age of History Games? Tell a friend!

  • Posts

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Age of History Games