Jump to content
Age of History 3


Choosing Scenario Isn't Working.

Recommended Posts

As of recent (and by that I mean yesterday,) I had to restart my computer, but I'd accidentally left AoC on. When I restarted my comp, the game was uninstalled, this has happened to me with other games. Unlike the others, this has appeared to corrupt my scenario files. I've tried reinstalling multiple times, all failed to work. Before restarting my pc, I had created copies of my scenarios, so they shouldn't be corrupted, yet they are lol. Whenever I try to change the scenario, it takes me back to the main menu screen. I know a friend who's had this before. The only way I've solved it was removing my scenarios. Is there any way to uncorrupt them or to fix the game? Any help would be appreciated lol. 

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Tell a friend

    Love Age of History 3? Tell a friend!

  • Posts

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Age of History Games