Jump to content
Age of History 3

Recommended Posts

Ever since I upgraded windows 7 to 10 when I open the game from either Steam or the exe file in the game folders and it'll say running then crash after anything from a second to thirty. I have jre 3.1, my java and Windows are both up to date. I've tried uninstalling and reinstalling, verified the integrity of the game files, ran it in compatibility mode for windows xp, vista, 7 and 8. I uninstalled and reinstalled Steam as well. I've tried every solution I've found, including the one Łukasz has provided, and nothing works. My PC is also more that good enough to run the game,

Edited by INeedMentalHelp
Missed information

Share this post

Link to post
Share on other sites

I have the same problem. I bought the game about 5 days ago and since then I didn't played it because I can't even run it. I tought that it won't open because I installed some mod, then reinstalled game and it still didn't worked. My PC is also more than good to run it.

Edited by HasinaSvekrva

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Tell a friend

    Love Age of History 3? Tell a friend!

  • Posts

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Age of History Games